Windows 8 (64 bit)

rupro's picture

 Trying to install SciWorkplace 5.5 on a new Windows 8 (64 bit) machine. The setup hangs trying to install TCI Latex. Does anybody know a workaround?



This issue is not specific to

This issue is not specific to 64-bit versions of Windows.

We have had some reports when installing to a new ThinkPad and some other computers where the TrueTeX installation fails and then hangs the main install, showing the message, "Installing TrueTex. This process will take a few minutes...". We have not had direct experience with this problem, so have had to rely on customer reports. Hopefully the following information will provide enough clues to solve the problem.

We believe the problem is caused by a virus checking or similar program preventing the TrueTeX install from being automatically launched by the SW install. During the SW install, it silently launches the TrueTeX installation, and then waits until the TrueTeX installation is complete. Since the TrueTeX install never completes, the SW install hangs.

In some cases, it was sufficient to close processes using the Task Manager. One customer reports, "I have Kespersky antivirus and after your mail I explicitly terminated the antivirus process and all its sub-processes. After that when I installed work space, it was successfully installed." Another customer reports, "I finally got it working. I had temporarily disabled Symantec, but that didn't get it working immediately. I think the program that I closed from the Task Manager that finally worked was rtvscan.exe". A Google search for "rtvscan.exe" finds, "rtvscan.exe is an executable of the Symantec Internet Security Suite. It is responsible for the execution of real-time virus-scanning in order to detect virus infected files as they enter your system."

We have also had reports from customers where they uninstalled the Symantec program. They then installed SW without problems and then reinstalled Symantec.

We have had a similar report with respect to Bitdefender Internet Security. Deactivating this program was not sufficient, the customer had to uninstall Bitdefender, install SW, then reinstall Bitdefender.

Another possible solution is to start Windows in Safe Mode and then install the program. As far as we know, everyone who has tried this method has succeeded. See for information from the Microsoft web site on starting in Safe Mode.

bguler's picture

I recently bought a thinkpad

I recently bought a thinkpad laptop, and I am having the same problem. I am trying to install SWP 5.5 both in normal mode and safe mode, but it does not work. The only antivirus program I have is windows defender. As soon as it strats installing, it hangs up and never continues. Any further suggestion?

If the install runs normally

If the install runs normally until it reaches "Installing TrueTeX..." and then stalls, then no, there isn't any additional advise other than what has already been posted.

If you are seeing some other message, then post that message.

bguler's picture

 It does not come to that

 It does not come to that point. When I start installation, after the initial screen, showing the version of SWP I am installing, goes away, the installation stalls. I tried older versions of SWP, and then I receive the following error message: "An error occurred while launching the setup. The remote procedure call failed." 

I haven't heard of this error

I haven't heard of this error before. A web search for the error message implies that there could be a virus problem, or your Windows computer isn't configured properly with the RPC service not running. Making sure the current Windows Update patches were applied was also suggested. I don't have a specific recommendation, especially if the error also happens in safe mode.

You can try using Bing or Google to search for "An error occurred while launching the setup. The remote procedure call failed." (including the quotes) and work through the results to see if any of the suggestions match up with your system.

bguler's picture

 I don't think it is related

 I don't think it is related to any virus issue. First the laptop is new and everything about the laptop is checked by our IT guy in the company. Second, I installed several other programs on the same laptop, and haven't experienced this problem. Third, other than the installation of the SWP everything runs smoothly on the laptop. Fourth, this error message only appears if I try to install older versions of SWP. If I install SWP 5.5, the installation just stalls as soon as it starts, and I receive no error message or anything indicating progress in the installation.

Are you installing from a CD

Are you installing from a CD or from a download file? If from the CD, then usually the autorun install starts first where you enter the serial number and this selects the appropriate install program to launch. If that's how you are starting the install, then maybe there's something wrong that's stopping the autorun from launching the appropriate install program. In this case, try browsing the CD and find the appropriate setup program. Below the swpswsn55 directory on the CD there are three install directories, setup for Scientific WorkPlace, setup_sw for Scientific Word, and setup_sn for Scientific Notebook.

If installing from the CD fails, you can try using the download file. Download links are available at

bguler's picture

 Nope. I tried the

 Nope. I tried the installation using the download file I obtained from the link you posted.  

Sorry, but I have no idea and

Sorry, but I have no idea and it's difficult to guess without an error message being presented. Below is information we have for InstallShield related errors. The install program does present an error for the issue described, so the information may not apply, but this is the only other information I have.

We have had reports of errors from InstallShield when the setup program is started. From what we can tell, this seems to be some interaction between InstallShield (the install program) and Windows. The error message is of the form:

An error (-5009 : 0x8002802b) has occurred while running the setup

Customers have reported solutions using suggested work arounds for the errors. The following steps worked for error -5009 : 0x8002802b.

1. Open the folder located at C:\Program Files\Common Files.
2. Locate a folder called InstallShield.
3. Right-click on the folder and select the option Rename.
4. Rename the folder to something like InstallShield_OLD.
5. Close the folder and try to re-run the SWP installation program.

This same advice seems to apply to other InstallShield errors, including -5003, -6005, and -6009.

A customer who was experiencing the -6005 error reported that the above did not work, however going into the properties of the setup.exe and running it in compatibility modes for XP SP3 worked.

The following worked for error -5006 : 0x80070002.

The root of the problem comes from the install engine evaluating the Windows Directory incorrectly. The install attempts to find the Fonts folder and it is 'missing'. To solve this manually add the folder where the install engine expects to find it. Therefore adding a folder at: C:\Documents and Settings\CurrentUser\Windows\Fonts (where CurrentUser is the User Name of the logged in User) will allow your install to succeed. If using Windows 7, then the C:\Document and Settings directory doesn't exist. Instead, create the directory C:\Users\CurrentUser\Windows\Fonts (same comment as above about CurrentUser).

If you continue to have difficulties, then next step is to try to locate information that has been successful for others that have experienced similar error. Do an Internet search for the following:

InstallShield error "-5009" 0x8002802b

Substitute the error numbers you see when doing the search. Use the quotes around the major error number (-5009 in the above example) otherwise most search engines see the minus as an instruction to exclude results containing 5009.

bguler's picture

 The problem seems to be

 The problem seems to be related to the InstallShield Wizard. When I start installation, The InstallShiel Wizard comes out for a few second, and then I receive the following error message, and the installation quits:

"An error occurred while launching the setup. The remote procedure call failed."

Does such an error message help? Otherwise I receive no other messages since the installtion quits in a few seconds.

Hope you can help me with this! I desperately need to install SWP asap!

Sorry, don't have any other

Sorry, don't have any other advice. I did another search for "An error occurred while launching the setup. The remote procedure call failed." (the search included the quotes) and found only two suggestions. One was that there was a virus problem and the other was that there was a MBR problem. MBR is Master Boot Record and the person posting the message was able to solve the problem only after a low level hard disk format.

rupro's picture

 Booting into Safe mode

 Booting into Safe mode worked! Thank you for a prompt reply!

Philm's picture

I have the same Problem with

I have the same Problem with a brandnew Windows 8.1 Notebook (ThinkPad T540p). Install hangs when beginning to install TrueTex. I extra uninstalled the antivirus software, but it didn't help.

The Computer is absolutely properly installed, I can use every remote control program and can install every other software except SWP (even SNB), especially with all InstallShield Versions I know (InstallShield Script and InstallShield MSI).

I am a bit disappointed, that you are not further investigating this problem. For me it is very clearly an installer incompatbility of SWP with a (not few) number of Windows 8 machines.

For me, one cannot longer speak about full compatbility of SWP with Windows 8 !

MacKichan should think about building a new installer, maybe with MSI Technology.
At least I would demand a hint where logfiles are and that the logfiles allow to narrow the potential error points of the setups!

I will try now the Safe mode. For me the necessity of the Safe mode is a sign of a potential driver Problem or so. Every untrusted Driver can be installed like this too.