Saving documents

cherif's picture

 I use ScientificWorkPlace 3 in XPpro for long time. I had to re install it. I can create documents, but when i try to save, le software closes and the document is lost! What can I do?


Here's my only guess:   We

Here's my only guess:


We have had reports of a problem where the program crashes whenever a menu item that uses a Windows common dialog opens.  The Windows common dialogs are used for File, Open and File, Save As (which always appears when saving a new document).  The only common aspect that we noticed is the the problem happens with Acer computers.

In looking at system information files that have been submitted by customers reporting the problem, the only thing that seems to be in common is that this problem is occurring on Acer with "Acer Empowering Technology" software installed.  Customers have reported no longer experiencing the crash after uninstalling the Acer Empowering Technology programs.  We do not have any Acer computers available to us so have not been able to directly test this ourselves.  However, removing the Acer software has worked for customers that have experienced this problem.

cherif's picture

 Thank You very much for your

 Thank You very much for your time.

1)My computer is compacq CQ2200.

I faced the same problem, with the same computer in 2009. I found an explanation in The Mackichan conferencing system I think. I have lost the precise reference. I remember just that it was recommanded to download and install some file. Is-it possible to find this conference again?

2) I do not remember what I dit, the software works perfectly since septembre 2009. Last week I had to re install the program but it dose not work. When I try to save or open a new document, the program crashes.

Thank your for hepl.

The available updates for

The available updates for Version 3.0 can be found at:  Perhaps it is the SmartHeap update that will help with this problem. 

cherif's picture

 Thanks I am trying to change


I am trying to change te root of the temp directory.

1)I created a director c:\swp30\temp

2) I open the program, then Tools, user setup, Files ,Directory Groups,  File Types, temporary File, Modify. I found un long root for temp Directory, but I can not modify it. In can not write. 


What happens after you use

What happens after you use Tools, User Setup, the Files tab, click on the Temporary Files line to select it and then when you choose the Modify button?  You should get a dialog that lets you navigate to the directory you want to use as your temporary directory.

cherif's picture

 When I choose the Modify

 When I choose the Modify button I get the dialog Modify Location where I see the different directories that lead to the Temp directory, but  I can not modify them.

Is there another way to modify them?

Double clicking on a

Double clicking on a directory in the dialog doesn't change the selected directory?  You should be able to double click at the top level (c:\) to update the list to show the directories at that level where swp30 and then temp would become visible.

The alternative is to directly use a registry editor program, but this is recommended only if you are comfortable in using a registry editor program.

cherif's picture

 The problem of saving

 The problem of saving documents is solved as follows in XP: right click on SWp30, properties, compatibility, windows 95.

After that I can create and save documents, open created documents and so on.

Thank you very match for your help.