`tcilatex.tex' not found

Chris's picture

Hi users of v6.0.30, may I know if you still experience the problem when you imported works from v5.5 which contain graphics, etc and when compiled, received the error "! LaTeX Error: File `tcilatex.tex' not found."?

jm's picture

I haven't had this problem

I haven't had this problem since following the instructions for Updating the TeX filename database at


Chris's picture

Thanks Jm. Tried with Windows

Thanks Jm. Tried with Windows MiKTeX by refreshing filename database but can't seem to get the compile to pdf to work.

Also, I would assume you are using Mac version of SWP 6.0.30. Do you experience frequent crashes of the program on Mojave? I always have that error and the error is always pointing to xulrunner if I remember correctly.

pviton's picture

With respect to the original

With respect to the original tcilatex question: you're sure that it's actually in the miktex search path, no? It's been a while since I've used miktex and there may be an easier way to do this, but so long as miktex is in your path you can do, from a dos command prompt:

kpsewhich tcilatex.tex

and it should tell you where tcilatex is, if found. (If this seems not to be working, do kpsewhich article.cls, which is guaranteed to be there if miktex is working correctly).

Chris's picture

Hi pviton, I did as

Hi pviton, I did as instructed

kpsewhich tcilatex.tex

and there is no result. But when I try with kpsewhich article.cls, yes, I can see the location of the file. Hence, this conclude that the tcilatex.tex is not in my system. Emmm...

Since kpsewhich can't find

Since kpsewhich can't find tcilatex.tex, the directory containing this file must not have been added to the MiKTeX search path.  From http://support.mackichan.com/a/solutions/articles/6000155453 :

From the Windows Start Menu find the MiKTeX group and start the "MiKTeX Console" program. A selection can then be made to run in administrative mode or user mode.  Select Settings item on the left and then the the Directories tab.   Click the plus icon and then Navigate to the directory c:\texlive\texmf-local and with this directory selected click Select Folder.  Use the Tasks menu and select Refresh file name database to make sure files in the added directory can be found.  The MiKTeX Console program can be closed when these steps are completed.  

Version 6 doesn't need tcilatex.tex, but the reference is retained when documents using tcilatex.tex are imported.  So, an alternate solution is just to delete the \input{tcilatex} line from the document preamble.

Chris's picture

Excellent solution, George.

Excellent solution, George. Problem fixed! Thanks

Also, George, do you know why the v6.0.30 program keep crashing when we are manipulating or moving math expressions and displays? It will be great if this can be fix.

jm's picture

I am indeed running SWP

I am indeed running SWP 6.0.30 on Mojave (10.14.6 to be exact), so I have no experience of using it with MiKTeX.

I certainly have more crashes with SWP 6 than I think is reasonable but I have never checked out whether they have to do with xulrunner. How would I do that? If we could pin down what causes crashes in SWP 6, it might help the folks at MacKichan to reduce them.

What seems to cause crashes most easily with me is manipulating and moving math expressions and displays. So, frustrating as it is, I just save the document when about to do such operations and then just live with the time taken to re-open it if it crashes. Not a great solution but just about liveable with as long as the next version of SWP 6 is not too far off. I had been anticipating it would be less than one and a half years and desperately hope it isn't going to be long now!

Chris's picture

When SWP crashes, I received

When SWP crashes, I received the error in the form of a popup and when I read it, there is a mention of xulrunner. I have reported the matter regarding xulrunner and apparently it is due to the Mozilla framework that they are using for the latest version 6. It also appear that the condition of crashes for me is the same as yours when I am manipulating, moving and sometimes correcting previously typed mathematical equations. I didn't report to them on these and I am waiting for the next release too.