PDF preview problem

Giorgos's picture

Hello to everyone! Thanks a lot for the 6.0.30 version! I need your help with an issue that I have with the PDF preview. I have SW 6, and even though I have no problem editing, the PDF preview doesn't work properly. I have Windows 10 Pro, 64-bit edition. A few months ago I had to format my PC. After reinstalling SW, I couldn't export PDf files properly. Actually, while I am trying to use the PDF preview, the process starts normally and then stops. Do you have any idea of how could this problem be resolves?

The only guess from the

The only guess from the information in your message is that the TeX Live installation failed.  Try installing TeX Live separately from SW.  See http://support.mackichan.com/solution/articles/6000046747-tex-live-for-w... for the steps.

Giorgos's picture

Thanks a lot George for your

Thanks a lot George for your reply! Unfortunately it didn't work... The problem still insists. The .sci file opens normally, but when I demand to pdf preview, the black window is running and when it closes, the window showing the number of passes remains open without any pdf outcome. At the end there appear only the .sci and the .bak file.

pviton's picture

You might try the

You might try the following:

Can you successfully pdf-preview the Std Latex Article shell? If so, then there's something wrong with your document.

If not, start a DOS session (winKey+r, then type in: cmd) issue the command

pdflatex -v

you should see a bunch of information lines; the first line should end with something like (TeX Live 2018 ...). If you don't see this, or get a message saying that pdflatex can't be found, then there's something wrong with the TeXLive installation. One thing to look at is your path. Still in the DOS session, issue the command


In the result you should find an entry like


(yyyy is a year, like 2018) which should point to where TeXLive is installed. Make sure that this entry has no spaces in it, since I think that the texlive programs may have problems with spaces.

If none of that helps, then back in SWP6 and with the Standard Latex Article on screen, do File > Export Tex and give the output a name (with extension .tex). Start a DOS session and navigate to the TeXLive bin\win32 folder (using cd). There should be a file called pdflatex.exe there. (dir pdflatex.exe). Now try to compile your saved TeX file:

pdflatex "c:/myfolder/myfile"

where (1) the argument to pdflatex should be in quotes (2) you should omit the .tex extension and (3) you should use / as path separators, not \ as is normal in windows. (If pdflatex starts a nd then throws an error, hit Ctrl+C a couple of times to quit). That should produce a pdf file in bin folder (which you can then delete, along with the aux and log files). Let us know what happens.

Giorgos's picture

Thank you very much for the

Thank you very much for the advice,pviton! The problem still insists. I cannot pdf-preview Std Latex article. I folowed all the steps that you suggested and all seems to be fine. Namely, the pdflatex in the DOS session is in the correct form. The path appears as the entry that you have written, so the texlive is correctly installed and without spaces. Unfortunately the DOS compilation of the tex file didn't work because it appears an error saying that it cannot find the path of the file, even though I have written the path as advised. Nevertheless I tried to compile the tex file with tex maker using pdflatex in windows environment and it compiled it with no problems. Moreover, the problem with the pdf preview seems to appear only to new sci files. Sci files that I have created a year ago (pre format) are working smoothly. No pdf preview problem appears.

pviton's picture

Let me be sure I understand:

Let me be sure I understand: with your current setup on win10 (after reformatting your hard disk) you CAN pdf-preview sci files created before the re-format, but you CANNOT pdf-preview newly created sci files? If this is so, then I'm out of ideas, but clearly there's a serious problem.

Here's one last thing you could try, just for fun:

In your top-level SWP6 installation folder (the SWP folder, typically under C:\Program Files (x86)\MacKichan\), find the file pdflatex.cmd. Open it in a text editor. On a new line at the end of the file add


then save the file.

Now open SWP6 and open the Standard latex Article (if it isn't already open). Pdf-preview.

What should happen is that a DOS window should open, recording how the pdf-latex compilation goes; but this time it won't automatically close. (At the end of this you'll see the line"Press any key to continue..."). What you should do now is copy the contents of this window to a file. If you know how to do this, skip the next paragraph.

To copy the material: click on the icon at the top-left of the DOS window. In the drop-down menu, select Edit, then Mark. Place the cursor at the bottom-left of the window. Holding down the left mouse button, move the mouse horizontally to the right as far as it will go, then vertically up until everything is highlighted. Release the mouse button. Then again click on the top-left icon. In the drop-down menu, click Edit then Copy. At this point the highlighted material is on the clipboard.

In the DOS window, press any key to close the window. You can now
open a text file and paste in the contents of the clipboard. Save the file, zip it up and post the result here.

Finally, go back to pdflatex.cmd and remove the pause line you entered.

(The point of all this is to see which sci file SWP6 is trying to compile, and which TeXLive installation it's trying to use).

Giorgos's picture

Thank you very much for your

Thank you very much for your help, pviton! Well, I just realised what is happening, which maybe of some help. At the end, the problem is not in pre and post formating files. Sci files that I have in my Dropbox work perfectly but files that I am working locally cannot pdf previewed. For instance, editing a file that I have in my Dropbox works fine. Copying the same exact file and editing at my desktop doesn't produce a proper pdf file. I don't know if something is happening with the path of the file.Nevertheless, I attach the zip file as you asked.Hopefully, it'll may be of some help!

pviton's picture

If you look at the txt file,

If you look at the txt file, you'll see that we have the lines:

C:\Program Files (x86)\MacKichan>pushd "C:\Users\ganas\OneDrive\ˆ³³Á±Æ±\SWDocs\untitled2_work\tex"
The system cannot find the path specified.

which is why it's not working. I don't know if it's because of OneDrive or because of the non-Roman characters in the path (the bit after OneDrive), but with any luck the tech people at Mackichan may be able to help. (I've never used OneDrive myself: maybe it's a question of permissions?)

The other thing you could do, which I'm reasonably sure would solve the problem, is to change where you store your SWP6 files. You can do this via Tools > Preferences ; and then at the bottom of the General tab.

Giorgos's picture

It worked! Thanks a lot

It worked! Thanks a lot pviton! It was because of OneDrive.When I installed again the Windows I have accepted, without noticing, that all files are saved by default at OneDrive. Once I changed that and following your instructions for the place where SWP6 files are stored, everything started to work smoothly...
Thanks a lot for your help and for your patience!