Problems with including PDF in SWP document

rdt's picture

Hi, I've created some PDF documents as outputs from a statistical package (Stata) on my university's server. I want these figures to appear in a SWP document. I know and have used the basic code needed to bring in a PDF in the past, e.g., (note that I'm changing a couple of filenames and folder names for privacy, but I have learned not to have subscripts in these paths as that can cause errors),

\begin{figure}[!h]
\begin{center}
\includegraphics[width=120mm]{Figure.pdf}
\caption{Caption describing the Figure}
\label{figure1}
\end{center}
\end{figure}

I've used such code and successfully compiled PDFs with the graphics appearing as needed. Today I was trying to incorporate PDFs in the same way and getting frustrating error messages. E.g.,

<G:/File1/File2/InfArndThreshold.pdf, id=656, 483.37025pt x 10
3.14435pt> <use G:/File1/File2/PaperGraphics/InfArndThreshold.pdf> [69 <g:/File1/File2/PaperGraphics/InfArndThreshold.pdf
Warning: pdflatex.exe (file g:/File1/File2/PaperGraphics/InfArndThreshold.pd
f): pdf inclusion: Page Group detected which pdfTeX can't handle. Ignoring it.
>] G:/File1/File2/PaperGraphics/Other.pdf
Error: PDF version 1.6 -- xpdf supports version 1.4 (continuing anyway)
Error (0): PDF file is damaged - attempting to reconstruct xref table...
Error: Couldn't find trailer dictionary
Error: Couldn't read xref table

Error: pdflatex.exe (file G:/File1/File2/PaperGraphics/Other.pdf
): xpdf: reading PDF image failed
 ==> Fatal error occurred, the output PDF file is not finished!
[pdfLaTeX finished]

I'm not so worried about the errors that the compiler says it's willing to ignore, but much more the fatal ones. Any advice?

"Error: PDF version 1.6 --

"Error: PDF version 1.6 -- xpdf supports version 1.4" is the fundamental error.

If you have Version 5.5, update to the newest build.  This will give you a version of pdflatex that would allow inclusion of version 1.6 .pdf graphics.

If you have Version 5.0, then you will need to somehow create .pdf files that use an earlier PDF version.

altintas's picture

I have exactly the same

I have exactly the same problem. It may be related to verson of the PDF reader. I used a simple test like yours, and got the same fatal error. I have Adobe 8.0. Somehow, we may haev to install earlier versions of PDF reder/writer, but I hav eno idea what are they and where I can get them.