Preparing SWP/LaTeX Files for Submission to Preprint Processor

I have been attempting to prepare a file prepared with SWP/LaTeX for processing by the preprint automatic processor. George Pearson suggested that I prepare the file in Standard LaTeX and then save it as a Portable LaTeX file before submitting it. This procedure works properly for files that have no graphics inserted. That is, the processor produces the required *.ps, *.dvi, and *.pdf files. When I added either *.eps or *.jpg graphics using the proper relative addressing scheme required by the processor, their system produces the *.ps and the *.dvi files properly but refuses to process the files further to generate the required *.pdf . file.

Has anyone had experience preparing SWP/LaTeX files for submission to What problems have you had getting the figure files into their system?

Inspect the .tex file that is

Inspect the .tex file that is being generated and locate the graphics file.  It will look something like:

%{\special{ language "Scientific Word";  type "GRAPHIC";
%maintain-aspect-ratio TRUE;  display "USEDEF";  valid_file "F";
%width 0.4869in;  height 0.6746in;  depth 0in;  original-width 0.4566in;
%original-height 0.6434in;  cropleft "0";  croptop "1";  cropright "1";
%cropbottom "0";  filename '../Graphics/barry.jpg';file-properties "XNPEU";}}}%

In this case the graphics file is named barry.jpg and is included in the document using the relative path ../Graphics.  If your graphics are in the same directory as the document then there shouldn't be any path included before the file name of the graphics.  If there is a path then you can directly modify the .tex file with a text editor and delete the path portion from the \includegraphics macro.

A setting to check in SW is to use Typeset, General Settings, the Portable LaTeX Graphics Settings button, and then make sure in the Export Options you have "Leave graphics unchanged" for the appropriate graphics type selected under "Apply Export Options to".  Select "All graphics" if you want to apply the Export Options to all of the graphics in your document when you save for Portable LaTeX.

Thank you so much for your

Thank you so much for your advice. Unfortunately, the procedure to get a Standard Latex of Article type through the processor was a bit more complicated. I will try to give my experience with the so that any future questions on the subject can start from both your valuable input and from my experiences.

Here is the process:

1. Take all the figures and all links to the figures out of the Standard LaTeX SWP document and save the document in its own directory.
2. Make a new figures with SigmaPlot and output it as a *.eps file (fig1c.eps). The LaTeX processor apparently will accept only *.eps figures made with particular programs and will not accept ones generated from any PowerPoint file that has been wrapped in an eps wrapper. It does accept *.eps files from SigmaPlot, Adobe Illustrator, MatLab, and some other programs--if they have been stripped of extraneous information with the following process.
3. Compress the file with GSview and Ghostscript (use PS to EPS option in GSview)
4. Put the compressed file in the directory with the Standard LaTeX SWP document
5. Insert the compressed file into the Standard LaTeX SWP document and save it
6. Save the document as a Portable LaTeX document in the same directory
7. Use NotePad or TeXworks to make sure the figure uses relative addressing of just the graphics file name including the eps extension
8. Add the command \usepackage{epstopdf} immediately after the \usepackage{graphic} command in the LaTex file using NotePad or TeXworks
9. Check to make sure the LaTeX file compiles properly with TeXworks and MikTeX
10. Submit the LaTeX file and all figure files to the processor

The implication is that we have to prepare all the graphics files as *.eps files and that I have to compress them before inserting them into the document.

Good Luck is required after that for this arcane and undocumented process required by .

The above procedure has an

The above procedure has an error in step 8. It should be:
8. Add the command \usepackage{epstopdf} immediately after the \usepackage{graphicx} command in the LaTex file using NotePad or TeXworks