etex in extended mode

wuzhang's picture

Hi folks,
I copy tex file from MikTex to Scientific Word; in MikTeX, everything is fine; but in SW, I go the following error message.

! Package etex Error: This package may only be run using an
(etex) etex in extended mode.

Could someone help me with that?

Thanks,

Wu

You must have added a package

You must have added a package or done something else that causes eTeX to be required.  The TrueTeX Formatter does not include eTeX.  Compile the document using MiKTeX.  You can continue editing the document using SW.

wuzhang's picture

Hi George, First thanks

Hi George,
First thanks for your response. I checked the CTAN web, there are two packages related to etex:

1. http://www.ctan.org/pkg/etex

2. http://www.ctan.org/pkg/etex-pkg

But the problem is that in 1, there are so many files; while in 2, there is only one file. I do not know how to install either of them.

Any thoughts?

Best,

Wu
P.S. You're right-I can edit file in SW; but you know I have to copy back and forth...

You can use the Expert

You can use the Expert Settings dialog to have SW compile using the alternate TeX/LaTeX installation.  You may need to copy files or otherwise include the files that are unique to SW with your other TeX/LaTeX installation.  The directories styledit, SWmacros, and SWmisc below TCITeX\TeX\LaTeX covers what would be needed.