Graphics in subdocuments don´t appear at all in masterdocument pdf file

heike.m's picture

Hey,

I use SWP 5.5 on a Windows XP machine.
I want to create a master document, named Diss.
The master document has several subdocuments. I use ''import content'' for the subdocuments, since I have the content for each subdocument created as a normal document (here: NormalDocument1).
The graphics from the NormalDocument1 are saved in the same directory as the Masterdocument and the subdocument "doc1".

Then I compiled the Master document with pdfLatex button. (I have to use the pdfLatex button, because my final document contains landscape package).

Problem: The grahpics dont appear in the pdf Master document (Diss.pdf).
Instead the path in the compiled master document refers to the file named graphics, which was created when I imported the content from the Normaldocument1 to the Subdocument doc1.

I would like the master document shall use the subdocument graphics, as they are in the original document ''Normaldocument1''.

If I compile the master document with the dvi setting, the graphics appear correct in the master document (see: Diss.dvi).

  • I already tried to change the relative graphics paths and I tried (indepently) to change the output choice in the master document (to pdf output).
  • In both cases I open, re-opened, saved and so on the subdcoument doc1.
  • I also checked if it matters, if the graphics are .wmf or .png or .jpg with respect to the pdf LatexOutput.

Since I need to compile the master document in the final version with all my subdocuments via pdf, I don´t know what to do next.
Any suggestions? How can I solve this?

Thanks a bunch,
Heike

 

AttachmentSize
Diss.pdf39.4 KB
Diss.tex3.35 KB
Diss.dvi5.63 KB
doc1.tex3.08 KB
NormalDocument1.tex4.53 KB
NormalDocument1.pdf75.53 KB
AbbArbeitsmarkt1.wmf40.33 KB
AbbKonsumausgaben3.wmf106.18 KB
Bild1.png20.93 KB
Bild2.jpg38 KB
doc2.tex34 bytes

The way the graphics are

The way the graphics are being displayed is because that is what you asked for.  You have the draft class option turned on, so graphics are displayed as frames with the file name of the included graphics.  Turn off the draft option in the master document and you should get the graphics included in your PDF file.

heike.m's picture

Thank you! It worked.

Thank you! It worked.