Problem with pdf preview

poleka's picture

When i try  to compile tex document to pdf with imported pictures, the SWP crashes without any error msg. At the bottom i can see the msg "generating graphic file..." and it crashes. There is not any problem when compiling without images. I have Wnd7, and it works earlier. Note that dvi preview works fine.

mako's picture

Hi, I have a similar

Hi,

I have a similar problem.

here is my error message:

! Missing $ inserted.
<inserted text>
                $
l.1256 .../Local/Temp/graphics/abbildung 1__1.pdf}
                                                  %
?

What can I do? I've already tried the graphic export settings described below.

 

This error is caused by the

This error is caused by the space in the name of the graphics file.  A work around is to change the way SW names graphics files that are generated when compiling for PDF. Select Typeset, General Settings, choose the PDF Graphics Settings button, then choose the Graphics File Naming Options button and select "Generated filename". Use OK to close the open dialogs.

mako's picture

Thanks a lot for the

Thanks a lot for the help.

Now I have another problem. I need to change the settings for the line spacing. I've changed it in the 'options and packages', but it remains the same, when i compile it to pdf. Another question is: how i can change the font size to 12?

 

If the information at

If the information at http://www.mackichan.com/techtalk/371.htm doesn't help, then you will have to post a sample document.

Use Typeset, Options and Packages the Class Options tab and then the Modify button.  Must typesetting specifications have an option to select 10pt, 11pt, or 12pt as the base font size. 

If you have further questions about these items, it would probably be best to post a new top level topic.

tomprice's picture

Hello, It would be difficult

Hello,
It would be difficult to diagnose the problem from the given information. May I suggest that you create a minimal (nonworking) example—a short document containing one graphic that causes a similar crash—and attach the wrapped document to a reply to this post. The wrapped document will contain the .tex and graphic files.
Regards,

--Tom Price

poleka's picture

I use SWP 5.5 2960, since

I use SWP 5.5 2960, since last post I notice that pdf compilation works fine with png and jpg files, does not work with bmp, emf, and wmf. I have to use vector graphics. Attached archive contains .tex and another archive with compressed picture.  

We have heard of problems

We have heard of problems where there is a crash when graphics are converted to .pdf for inclusion in documents being compiled for PDF.  We have not seen this problem here and do not know what exactly is causing the problem.  The problem happens only on certain limited systems and may be related to certain drivers or Windows updates.  Since we haven't been able to reproduce the problem it's not clear what is causing the problem.

A work around that has been reported is to change the graphics type that is generated when graphics are converted.  Select Typeset, General Settings, then choose the PDF Graphics Settings button.  If the default settings haven't been changed, in the Apply Export Options to group Selected graphics with the subentry Raster graphics will be selected with Export graphics as *.pdf in the Export Options group.  Change .pdf to .png or .jpg.  Then change the Selected graphics subentry to Vector graphics and again change the Export Options group from .pdf to .png or .jpg. and use OK to close the dialog.  If you are using Scientific WorkPlace, change the Graphics type for plot export to .png or .jpg.  Close the PDF Graphics Export Options dialog to save changes.

tomprice's picture

You file formatted correctly

You file formatted correctly for me. Perhaps you should post a copy of your log file for the non-working example you created.

--Tom Price

poleka's picture

..., but SWP crashes before

..., but SWP crashes before creates log file, i have found another way to make pdf. First: compile to dvi, second: print it from dvi previewer by printer like pdf creator

2nd2god's picture

I encountered similar

I encountered similar problems with pictex pics using the some springer style. And the same fix worked.

André