trouble getting shell to link w/ cls file

david.robbins@trincoll.edu's picture

Good afternoon. I received from a journal the attached tex shell file and cls file (attached here as txt file). Following the editor's instructions

"please transfer your tex-file according to template ACUTM that uses class file acta.CLS. The last file should be saved in the folder where your tex-file is,"

I put both files inside the folder \swp50\styles\acta, and attempted to open the tex file, only to get the message "Can't find file c:\swp50\styles\acta." Then I tried keeping the cls file in \swp50\styles\acta and moving the tex file to the desktop and various other locations, only to get the same message. Also tried changing file extension of cls file to cst, still no go. Again, the attached file acta.txt was originally acta.cls, file extension changed to enable upload.

Would appreciate any suggestions - I will confess to being at least two academic generations older than a generic tex native speaker. Thanks very much.

AttachmentSize
ACUTM.tex8.46 KB
acta.txt57.29 KB

Steps for adding a new

Steps for adding a new typesetting specification for use with Version 5 are at https://www.mackichan.com/techtalk/421.htm

The .cls file would be placed in some directory below c:\swp50\tcitex\tex.  

The message about "Can't find file c:\swp50\styles\acta." has to do with finding a .cst file that is used to format the screen appearance of the document.  

On inspecting the .cls file, it is basicly a copy of amsart.cls.  SW handles front matter elements for amsart in a different manner than for other typesetting specifications such as article.  In particular, the \address macro is used.  So, in this case, you would create c:\swp50\Styles\acta and copy into it amsartci.cst from the c:\swp50\Styles\amsart directory.  Also, to notify SW that this is an AMS style article, the file c:\swp50\latex.dat must be edited and the line "acta" inserted after [AMSBasedStyles].

You should then be able to open the .tex file and compile it.

david.robbins@trincoll.edu's picture

Thank you, George and John,

Thank you, George and John, for your help.

Here is one more situation, which appears strange. It's explained in the tex file attached, and illustrated in the attached pdf. Basically, in the body of the paper, \mathfrak characters appear as normal in the pdf when inline; but as subscripts they appear in some other font. And in the abstract, all \mathfrak appears in that other font. In the attached dvi file, however, everything appears appropriately. I can work around this, I guess, by printing the dvi and scanning back into a pdf, but it is cumbersome.

I note that this same sort of thing also happened when I was working with style svjour3.

John MacKendrick's picture

This does seem to be an issue

This does seem to be an issue with the PDFLaTeX system included with version 5.0. The mathfrak characters generated in version 5.5 do appear correctly in a PDF file.

You can try installing MiKTeX or TeXLive on your computer and use that to compile your PDF files. To have SWP compile a PDF file with MiKTeX, choose Typeset, Expert Settings, PDF Format Settings, Add/Modify, and change the dialog to look something like this:

As the executable filename, enter the path to the pdflatex.exe file on your own system (which will undoubtedly be different that what is displayed.) Then click OK.

To resume using TrueTeX, choose Typeset, Expert Settings, PDF Format Settings, and select TrueTeX PDF as the formatter. 

A disadvantage to using MiKTeX is that it does not have the graphic handling capabilities of TrueTeX.

david.robbins@trincoll.edu's picture

Thank you.

Thank you.

david.robbins@trincoll.edu's picture

Thank you.

Thank you.

John MacKendrick's picture

I notice that the contents of

I notice that the contents of the proof environment are not present on the screen. If you choose Typeset, Preamble, and add

\iffalse
\newenvironment{proof}[1][Proof]{\noindent\textbf{#1.} }{\ \rule{0.5em}{0.5em}}
\fi

to the list of commands and then save, close, and reopen the document, you will be able to view the contents of the proof. 

John MacKendrick's picture

To prevent the message from

To prevent the message from appearing, create a new subfolder under your \styles subfolder and name it \acta. Then copy sciword.cst from the styles folder into your new subfolder. Rename it acta.cst.

The .cls file is only used for typesetting the document. Place it into a subolder of the \TCITeX\TeX\LaTeX folder. 

See

https://www.mackichan.com/techtalk/421.htm

For general instructions on incorporating outside LaTeX files into the software.