graohics handling problem

pviton's picture

SWP 6.0.30 on Windows
=====================

1. Open SWP, do Insert > Image. Choose a .wmf file.
2. Click OK. A batch file runs twice, and the file
is imported. So far, so good.
3. Now select the image in the editor window. Right-click,
select Properties > Image Properties. The batch file
runs twice, again.

I thought that this problem --- the batch file runs every
time you want to do anything with an imported image
that uses Inkscape --- had been fixed a couple of years ago,
possibly in 6.0.27. Is this a regression?

Incidentally, in the Insert > Image dialog, typing or pasting
the path+name of your graphics file has no effect --- you still
get the Select Image File dialog. Was this deliberate? Is there
any reason not to allow the user to type in the graphics file name?

jm's picture

There is also the problem

There is also the problem that, in the Graph user settings > Placement box, the Location, Float and Baseline settings always revert to “Floating”, “None” and “Baseline” respectively when I open the box, no matter what they have previously been set to by selecting something else and clicking OK. (This is not the case with the Caption setting.) The same applies in the Image properties > Placement box to the Float and Baseline settings, but not to the Location settings.

This is an irritating bug and surely cannot be too hard to fix.

pviton's picture

I think the problem here is

I think the problem here is more than this particular Preference.

Try the following:

1. Open Preferences and set you start-up shell to
anything except the blank Latex Article.

2. Click OK, restart SWP. You should have your new
shell. So far so good.

3. Now open Preferences again and either:
(a) click OK without changing anything or
(b) without opening the General > StartUp Shell
tab, make some other preference change.
Click OK.

4. Restart SWP. Your shell is now the blank Latex Article.
It seems that clicking OK in the Preferences dialog
resets your start-up shell, whether you request a change
or not.

jm's picture

Another bug in SWP >

Another bug in SWP > Preferences > Start-up shell is that selecting "The last document saved, if it is present" seems to have no effect, at least under macOS Mojave 10.14.6.

pviton's picture

[Another Preference issue] It

[Another Preference issue]

It looks to me as if

Preferences > Editor > Spacebar after space
> [bullet] Does nothing

has no effect. (Unlike [bullet] Switches to math,
which works).

As it happens, this is harmless for typesetting
(but not for Direct Preview) since TeX ignores
extra spaces (unless they're required spaces).
But it's disconcerting to choose
this item, and see no effect when editing.