mostly tables

pviton's picture

SWP 6.0.29 on MS Win
===============
(original post had type: 6.0.28)

No need to belabor jm's point that the matrix
Properties bug is still not fixed, except to
remind people that this bug has been pending for
at least a couple of years.

On the other hand, one can only applaud the
fact that the bugs that were addressed generated
a quick update (in contrast to the time to get
to 6.0.27). I hope that this is now policy.

Tables
======

It seems to me that most of the table modification
features (in a table, do right-click, then
select Properties of Table) are not working
or not working properly.

A. From a default table, change Lines to
All / Solid. This works, but is not
remembered.

B. From the table with All / Solid lines, try to
set them to All / None. This does not work;
the lines remain on screen and the TeX file is unchanged.

C. From a table with all Solid lines, try
to change to All / Double. On screen, all
lines disappear, including the guide-lines
that were generated in (A). Typeset: lines change to
Double, as requested.

D. From C (ie double lines) try to
change to All / Solid. This works, and
the lines re-appear on-screen.
But it does not seem possible to remove
all lines.

E. On the Table tab, Max table width:
uncheck Automatic and enter 2 [cm]. As far
as I can see from looking at the TeX file,
this has no effect. Nor is the 2 entry remembered,
though the unchecked Automatic is.

F. With your cursor in one of the cells, try
to change vertical alignment to Top.
This setting is not remembered, and does
not appear to change anything in the TeX file.

G. Change the Extra Row Height to 2cm. This
is not remembered, and does not appear to
change the tex file in any way.

H. All the tabs on this dialog have an Advanced
Edit button. On none of the tabs does this
do anything.

I. On the Cells tab, change Text Wrapping from Wrap
to Don't Wrap. This seems to have no effect, either
on screen or in the TeX file. It is also not
remembered.

J. I have had a few instances where the
following happens: enter a table, put something
in each cell. With the cursor in a cell, do
right-click, then Cell-Group Properties. On the
Pacement tab, change Location = Floating to Displayed.
Click OK. Nothing happens. Click Cancel.
Back in the editor, try again. When the Placement
tab is selected, Location has in fact been
changed to Displayed. Click OK. Back in the editor,
everything has disappeared.

I can't duplicate this so I don't know what causes it;
but it has happened more than once with 6.0.28.

K. With the cursor in a table, is there any difference
between right-click+Table Properties, and
right-click+CellGroup Properties? They both seem to
bring up the same dialog. If there is a difference, when
should one use one rather than the other? If there's no
difference, why have both in the context menu?
It can only confuse.

L. I selected a Cell, then did CellProperties,
Lines / All / Solid. On screen, only the bottom of
the cell got a line. The typesetting was fine, however.
In a sense, this is unimportant since the typesetting
was correct, but it's frustrating to have to continually
check whether the software did what you asked it to.

M. minor point: I'd be inclined to say 'Single' Line
rather than 'Solid'. 'Solid' suggests a contrast with
eg 'dotted' or 'dashed', neither of which is available.
The real contrast is with 'Double', which of course is
two solid lines.

Conclusion
===========

It seems to me that practically none of the adjustments
to tables work as they should in SWP6. Tables are very important
to applied researchers, and I have to say that here,
at least, SWP5 is still the better choice.

Clarifiction
==============

Could someone clarify what happens in terms of
typesetting when you drag the left or right sides
of a table and how and when a tabulary is generated?

I did the following:
2x2 table, enter a letter in each cell.
Drag the right edge to say 300
Typeset. When you examine the TeX File, you have a tabular.
Now do Properties of Table.
Without changing anything, hit OK.
The table centers itself in the editor window.
Typeset. If you look at the TeX File, you now
have a tabulary.

Is it possible that this is a bug, and the tabulary
should have been generated when you dragged, rather
than when rather pointlessly opening and closing
the Table Properties?

I don't see how the generated width argument to
the tabulary environment relates to anything I
did (I dragged right to 300; the width of the
tabulary was 79.375mm). Can anyone help?

Desiderata
===========

Some things that I would like to see supported
in tables:

- decimal alignment in columns (LyX has this).
I might add that I'm not terribly concerned
whether this appears correctly on screen (though
it would be nice if it could): what matters
to me is the typeset appearance.

- longtables (LyX has this).

- booktables, Again, LyX has this.

- the ability to allow for wrapping in columns
by setting the column width. SWP5 has this
(so does LyX). If tabulary is a substitute
for this, I'l like to know how to use it.

- the Tables section of Creating Documents badly
needs expansion, to explain what all the various
options (are expected to) do. The current write-up,
occupying half a page, doesn't deal with any of
the modifications that ought to be possible.

Some other things
==================

Fragments: it does not seem possible to create
a fragment consisting of a TeX field. Is this
correct? Also, it does not seem possible
to drag entered fragements to other positions
in your document - is this by design?

Fragments: if you do a search for "fragment",
in the Help only the info for math fragments
appears. It would be helpful if the info
for text fragments would also be found.

Description lists: the Am Econ Review shell
(at least) still states that you should
double-click to edit the lead-in. Not so:
you can just type in the (yellow) box.

It's unfortunate that there's still no support
for math using Times fonts, even though there
appear to be several free solutions. Is there
some reason that these would not be expected
to work with SWP6?
ADDED: This is incorrect, and I withdraw it. As jm
points out below, mathptmx gives you Times in math.

jm's picture

Many thanks for listing all

Many thanks for listing all these issues with tables. Many of them I have encountered but have not explored sufficiently systematically to write a satisfactory posting. In my view, it should be a **very** high priority to fix them - up there with the matrix and graphics properties issues that I have been reporting repeatedly - because they are essential elements of many documents for which SWP 6 seems to have no workarounds.

A couple of comments on other issues you raised:

1. Fragments consisting of a TeX field. It is actually possible to create these, at least on a Mac. Create the TeX field in a document and copy it to the clipboard. Then right-click on any fragment in the fragments panel. One of the options that comes up is "Create fragment from clipboard". Choose that and the fragment appears in the list of fragments - though I haven't yet figured out how to determine where in the list it appears! (Don't ask how I found this out - as with so many things with SWP 6, I haven't found it documented anywhere and so had to discover it by trial and error.)

2. Times fonts. Doesn't adding the mathptmx package in the Typeset > Options and packages > Package options panel give a document in Times font? It certainly works for me. Or have I misunderstood what you are asking for?

pviton's picture

1. On creating fragments from

1. On creating fragments from TeX Fields: you're right, and this works on Windows too.

2. Times: Right again, and I withdraw my comment. For some reason I had convinced myself that mathptmx was Palatino, not Times.

Thanks for setting me straight!