Strange character

jm's picture

When I import TeX documents created in SWP 5.5 into SWP 6, I frequently get the character in the attached sci file added to math expressions. I have not discovered any role for this character - deleting it seems to make no difference to PDF output.

What is this character? And why is it added to math expressions?

AttachmentSize
strange_character.sci23.48 KB
Barry MacKichan's picture

It is the Unicode

It is the Unicode character 

U+2063 INVISIBLE SEPARATOR character (⁣)

Actually it is the UTF-8 representation of that character, which is \xE2\x81\xA3.

I'm not sure why it is there -- it is not useful unless between other characters. As you observed, it doesn't affect the PDF output, but we should be cleaning it up. 

This character does not (or should not) show up in any editor that is using the UTF-8 code page, which means you won't see it in PDF or in our  source view. My guess is that you were using something like Notepad and opened the file with ANSI encoding. There's nothing wrong with that, but our files are in UTF-8 format. When you use that, this character is invisible. I mention this only because there are many other characters in our documents (the minus sign in math is an example) that appear as gibberish viewed as ANSI text and appear as expected with UTF-8 encoding. 

 

--Barry

 

jm's picture

Many thanks for your response

Many thanks for your response on this issue. It has actually happened with many files created by SWP 5.5 that I have imported into SWP 6 that have not, as far as I am aware, ever been opened in anything other than SWP.

If it would help in sorting out how to clean it up to have some sample files, let me know and I can post some.

Just add the file as an

Just add the file as an attachment.  Scroll past the edit box to find "File attachments" where you can then select a file that will be added to the post.  Post a sample .tex file that imports with the extra characters.

jm's picture

I attach part of a document

I attach part of a document from SWP 5.5 that illustrates the "strange character" when imported into SWP 6.

It also illustrates that left-alignment of matrix cells is preserved in SWP 6 when imported from a TeX document even though there is no way I am aware of to achieve that alignment from within SWP 6. Or is there some way that I have not yet discovered?

It would be great if you could clean these issues up for the next release of SWP 6.

I don't see any strange

I don't see any strange characters, so I don't know if that's because I'm using the development version or for some other reason.  I noticed that the .sci file posted to this thread was last saved with an older version.  Version 6.0.27 is currently available from the download page.  Also, I notice that the Cyrillic code page is being used.  In Version 5.5, try using File, Save As and change the character set from Cyrillic to ASCII (Normal).

Unfortunately, it is currently a bug that the matrix properties dialog cannot be opened.  This is high on the list of things to be fixed.

jm's picture

I still get the strange

I still get the strange character appearing when I import the document to SWP 6.0.27.

I don't have SWP 5.5 on my Mac. How do I change the character set from Cyrillic to ASCII (Normal) directly in the TeX file using a text editor so that I can check out whether that makes any difference?