Beamer Currency Symbol Bug

jm's picture

When I enter a British pound sign £ in text in a Beamer presentation using the keyboard, it appears correctly on-screen and in the PDF.

However, when I enter a British pound sign £ in math in a Beamer presentation using the symbol panel, it appears correctly on-screen but incorrectly as $ in the PDF.

The attached files illustrate this. I am using Mac OS X version 10.11.6. Does the same apply with other operating systems?

AttachmentSize
BeamerCurrencySymbol.sci145.39 KB
BeamerCurrencySymbol.pdf65.43 KB
Barry MacKichan's picture

This is a TeX font problem.

This is a TeX font problem. The simplest cure is to change the font from the Beamer default. The easiest way to do this is to add a TeX field somewhere in your document; at the end works well.

The TeX field should be empty except the "Requires package" should be "lmodern". You can optionally set the name to "lmodern." Then generate a PDF preview again.

This should fix the problem.

 

jm's picture

Many thanks for responding so

Many thanks for responding so quickly. But could you be more specific about the precise entry in the TeX field? I tried what I thought your reply was suggesting but it did not seem to work.

Barry suggests using a TeX

Barry suggests using a TeX field.  Here are the steps to use this method:

- Position the cursor at a convenient location in the document, at the very end will work.
- Select Insert, Typeset Object, TeX Field to open the TeX Field Contents dialog.
- Place the cursor in the Requires Package text field and enter "lmodern" (without the quotes).
- Choose OK to close the dialog and add the TeX field to the document.
- Use PDF Preview to inspect the typeset results.

 

Two other equivalent methods to the same end:

1) Use Typeset, Preamble and add a line containing "\RequirePackage{lmodern}" (without the quotes).

 

2) Select Typeset, Options and Packages, the Package Options tab, choose the Go Native button and add a line to the Packages field that contains "{lmodern}" (without the quotes, but with the braces), and use OK to close the open dialogs.

 

Use only one of the three methods listed above.

 

 

jm's picture

Many thanks for the quick

Many thanks for the quick response. All 3 methods solve the problem.