import-tex partially broken?

pviton's picture

SWP 6.0.17 on MsWin
================

I tried to import a simple SWP55 tex file (just a table, no math) but SWP6 reported "Error running importtex". (The additional information involved something about a bad path). I tried this with a couple of other files, including one that I'm sure I'd previously imported, with the same result. The import filter never ran.

I tried this on three computers, all running 6.0.17. On two, running XP and Win7, I got the failure reported above. On a third machine, also running Win7, importing worked perfectly. Go figure.

Added: I don't know if it's significant, but the two machines in which importing failed were not connected to the internet, while the one that worked, was.

More:

1. The actual error was "Error executing command 'importtex' "

2. The more info box yielded:
Component returned failure code: 0x80520001
(NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsILocalFile.append]
3. Deleting the profile didn't help.

4. On the computer on which importing fails, the American Econ Review shell fails to compile. (The other econ shells, eg J.Pol.Econ, JEcPerspect, JInt'lEcon, JEconLit are all OK.) On the computer on which importing works, this shell also works.