file associations on win 7

pviton's picture

Comment : file associations on win7
SWP 6.0.17
======================================

If I double-click on a sci file on win 7 nothing happens.

If I run the command

assoc .sci

the result is : sciWordDocument. I then run

ftype sciwordDocument

and the result is:

sciWordDocument=C:\Program Files (x86)/MacKichan\SWP\swp.exe "%1"

This looks wrong to me: because there are spaces in the path
to swp.exe, I think you need to quote the entire path.
Could that explain why double-clicking doesn't work?
(I assume that the mixture of / and \ as separators
is OK).

Barry MacKichan's picture

I tried this, and it worked

I tried this, and it worked for me. Then I removed SWP and related files, and deleted everything SWP6-related in the registration database and reinstalled SWP. I then started changing registry items until double clicking (or its equivalent, entering a sci file path on the Command Prompt) until it worked. This indicates that it is the '/' in the path that is messing it up. This also indicates that the ftype you got is not the one being used. I can't be more specific right now without taking a lot more time.

However, right clicking on a .sci file, choosing properties, and selecting swp 6 as the opening program seems to set things aright. We'll be changing the installation program to get this right. Thanks for the tip.

 

--Barry

Barry MacKichan's picture

I was wrong. The registry

I was wrong. The registry setting that makes the differenct is the one given by ftype.