more on swp 6.0.12

pviton's picture

6.0.12 on MSWin
===============

*** verbatim background ***

I tried to imitate a book that
had code segments displayed against a
gray background. I entered some
verbatim text, and then used its
Properties to set the background
to gray. It looked more-or-less
OK on screen (though the background
seemed to be for the lines of text,
not the environment, ie the interline
space was not colored) but on pdf-preview
there was no colored background. Is it
possible to achieve this effect?
If so, how?

*** minipage ***

Enter a minipage, aka an "msiframe".
You get a frame as wide as the
text in the document editing window.
Now, without putting any text in the
frame, use its properties
("properties of minipage") on the
Frame tab to set the background to
some color. Click OK and OK again
to back out.

What happens is that the
frame resizes to something
that disappears as soon as
you put the cursor on it.
Presumably this is because
the default is 0 x 0. Probably
a bad choice: surely it ought
to agree with what gets inserted
by default.

If you had entered some text
before trying to alter the
properties, the frame resizes
to just-enclose the text on
the left and right but not
necessarily on the bottom.

Either way, the attempt to set
a background color doesn't work
on screen, though the PDF tgets
it right.

*** minipage - 2 ****

Enter say a 7in x 2in frame
and put some text in it. Preview.
The frame has collapsed to just-
enclose the text: in other words
you don't actually get a 7x2 frame.
Is this what is anticipated, or wanted?

It doesn't seem possible to
enter a verbatim in a minipage.
(in fact, if you try to tag existing
minipage text as Verbatim, something
strange happens). Is this legal
in LaTeX? If so, then SWP6 ought to
allow it; if not, then if you're in
a minipage, Verbatim ought to be
grayed out.

*** body text properties ***

In a previous posting I noted that
setting paragraph justification to
ragged-right using the properties-of-
body-text dialog doesn't work for
typesetting. After that post, I
noticed that you can get this
particular effect using the flushleft
tag on the paragraph tags drop-down.

It's not clear to me that it's
a good idea to have two ways to
try to achieve the same effect,
with different names, and where one
of them works for typesetting
while the other doesn't.

*** non-Roman scripts ***

Suppose I'm working in English, but I
want to add something (an epigraph,
for example) in a non-Roman script,
like Greek or Russian. Creating Documents
suggests that it should be possible
to do this, but it's not helpful
on how.

I tried adding the babel package,
with option "greek" to see if that
would add some options to the various
drop-downs. As best I can see,
it doesn't. So can we switch scripts
within a document, and if so, how?

*** Fragments ***

It does not seem possible to
create a fragment from a TeX field
whether encapsulated or not.
(I was trying to see if I could
get my SWP55 support for the booktabs
package to work). Is there some
trick by which this can be done?

*** web export ***

Export your document to a web
file, which on windows will
create a zip file. Now make a
change in the source, and re-export,
where you want to over-write the
old file. You're asked if you want
to over-write, but even if you
answer Yes, it seems that you can't
do it: the system responds
"Web file not created".

I deleted the old zip file and
re-exported. This time all that
was in the zip file was the xhtml
file: no css files. I tried this
several times, with no change.

I then closed swp and after deleting
the zip file, restarted it,
opened the sci file and then exported
it (again) to the web. This time
the zip file appeared complete.

It seems that web export is a
bit flaky.

*** personal bib file ***

Bibtex cannot find my bib
(personal bibtex database) file,
which is located outside the TL tree.
I've set the directory in the Preferences
> Typesetting dialog, the bib file
does exist in that folder, and
the Advanced Preferences
item swp.bibtex.dir is set
correctly. But bibtex (in View
Bibtex log) doesn't find it.

I'm pretty sure that this is a
recent problem. Could it be due to the
revised treatment of msitex.cmd?

*** preferences oddity ***

Assume that your preferences are
set to open the Std Latex Article
when you start the system. Start
SWP6, do Tools > Preferences. Select
the Start Up Shell tab. Without changing
anything, just click OK. You've just
(inadvertently) changed the Startup
shell to the Blank Latex Article. I
think this behavior is new to
recent updates of the system.