lists and matrices

pviton's picture

SWP 6.0.11 on MS-Win
================

Following the instructions in the
help file, I created a line

1,2,3,4,5,6

in text. I then selected it
and did Insert > Math. This is
supposed to change the text to
math, but it didn't do so.
What happened is that a pair of
math entry-point brackets ( [] )
got inserted at the end of the line.

I then re-selected the list
and tried again. This time it worked.
(I tried this several times to
check that it wasn't a one-off
problem: it wasn't).

Next, I put the cursor in the
math list of comma-separated numbers
and did Compute > Matrices > Reshape.
This is supposed to bring up a
dialog to allow you to choose
the number of columns. Nothing
happened.

Is the data-to-matrix feature
working? Or perhaps there are
additonal steps, missing from
the help file?

pviton's picture

... more I now think I know

... more

I now think I know why Reshape didn't work:
it was because I had the Help system open
(but minimized). If you close the Help
system, then the Reshape window should
re-appear.

I have to say, to me this represents
a serious usability problem with the
computation system. I know of no
other software that doesn't work
(or doesn't seem to work correctly)
when its own Help system is open.
If you can't fix this directly,
I think you need to do something
to minimize its effects: perhaps
put up an information box saying something
like "Please close the Help system
before proceeding".

Alternatively, would it help if the
user could open SWP's Help system in
Firefox, rather than its own (internal)
Help window? If so, then I think that
this might be the way to go, if only
until a real fix is forthcoming.

I still have trouble doing the
text-list to math-list conversion
whether or not Help is open; so I don't
think that's the issue here.