Wrong PDF characters in table

jm's picture

On my system (Mac OS X 10.11.2), PDF Preview of the attached file results in the wrong symbol replacing the on-screen < and > in the table.

This occurs only when < and > are entered as text, not when entered as math. But it surely should not occur with either.

AttachmentSize
TableSymbolWrong.sci48.92 KB

Seems to be something with

Seems to be something with the default font encoding used by pdflatex.  The other character that doesn't typeset as expected is |.  Correct results are seen by adding the fontenc package with the T1 font encoding selected.  Use Typeset, Options and Packages, the Package Options tab, the Add button, select fontenc from the list, and then use the Modify button to turn on T1 as the font encoding.  Attached is a modified version of the file you posted with this change (and some more sample characters added).

jm's picture

What you suggest works fine -

What you suggest works fine - many thanks. I used to use the fontenc package as standard but wasn't sure it was still necessary. It obviously is.

Another way, without adding

Another way, without adding the fontenc package, is to use Typeset, Document Format and change the TeX Implemenation selection from pdfLaTeX to XeLaTeX.

jm's picture

With SWP 6.0.10, XeLaTeX does

With SWP 6.0.10, XeLaTeX does not seem to work with filenames that have spaces that work fine with pdfLaTeX.

Is this something that is inherent to the current version of XeLaTeX? Or is it something that could be changed with an update of SWP?

Barry MacKichan's picture

This is probably due to the

This is probably due to the way we call XeLaTeX.  We will probably fix this quite soon.

—Barry