Version 6.0.6 with Mac OS X

jm's picture

I installed SWP 6.0.6 on a Mac running OS X. During installation, I specified the directory for my BibTeX databases but (as in previous versions) PDF Preview did not locate them correctly. Checking SWP/Preferences/Typesetting, I discovered that the field for the BibTeX database directory contained gobbledygook seemingly unrelated to what I had specified during installation. So it seems like there is still a bug in the installation process. Is that the case?

On the plus side:

1. when I specify the correct BibTeX database directory via SWP/Preferences/Typesetting, it is now sticky (the entry is still there after closing the dialog and re-opening);

2. the Terminal window now no longer appears (and so no longer needs to be closed manually) when using PDF Preview - a great improvement.

Many thanks for these improvements.

Barry MacKichan's picture

The bibtex database

The bibtex database preference used to be stored as a file -- some binary data that was serialized into 'gobbledygook'. In the process of streamlining this stuff, I changed it to a file path. Once the gobbledygook is replaced, it will not come back, and users who had never set the database preference with an older version will never see it.

—Barry

 

John MacKendrick's picture

Thank you for reporting

Thank you for reporting this. 

I am not seeing gobbledygook in the entry for BibTeX databases. 

I entered "C:\texlive\2015msi\texmf-dist\bibtex" when I installed. What did you enter?

Note that, for best results, one should usually just make both of the fields blank.

jm's picture

I think this issue has

I think this issue has probably been dealt with by Barry's later post. But in case not, what I entered when I installed was "/Users/malcomsj/Documents/Bibliographies"

Having the bibliography files in the default TeX location is actually very inconvenient with OS X because OS X expects all files you edit to be in the Documents directory and the TeX location is "hidden". Because I regularly add items to my bibliography files, having them in the default TeX location is thus (and leaving both fields blank) is not a convenient option. I can get TeX programs (such as TeXShop) that do not have a way to specify the path for bibliography files to find them in the Documents directory by specifying a global location for the BIBINPUTS environment variable and they all seem to recognize this. But SWP doesn't, which isn't a problem when I can specify the location directly but is the reason I don't want to leave both fields blank.

I am, by the way, really appreciating that I don't have to manually close the Terminal box when using PDF Preview. Thanks very much for fixing that.