Print book on both sides

rynek's picture

Hi,

I am using the book shell and want to print my document on both sides (default). But whenever I typeset the document there apperear several brakes in the pdf which have not been set. On various pages the pdf has brakes over about the fifth of the page instead of the usual brake from one part to the next (new line and little bit more space between these lines). These use brakes do also appear after a grafik and before the beginning of a new subsection.

I have no idea why these brakes appear and why only at some pages. I urgently need to remove these brakes!!

Would be very thankful for you help!!!

Many thanks!

 

Can anyone help???

From your description, it

From your description, it sounds like LaTeX has done the best page breaking that it can.  It could be that the typesetting specification won't move floating graphics to appear after the current section where they are located, so the graphic won't get pushed to the page after the section heading.  If it then can't fit the section heading and enough text on the page with the graphics, the section then starts on the next page.  This gives you the graphics and empty space on the last page of the current section.

This is a guess based on how LaTeX works, so the actual situation may be different.  You may need to supply additional typesetting instructions for LaTeX (maybe additional new page commands) or even text edits to get the text flow you are looking for.

rynek's picture

Thanks for your quick

Thanks for your quick reply.

I alreday thought that the problem is somehow related to floating graphics. But as this problem appears also on pages where there are no graphics I was a bit puzzled. However, the sections where the problem appears include graphics/tables - but the empty space does not only appear on the past page of a section - also (randomly) within sections.

So far, the graphics in the pdf always appear at the exact position where they are in the swp-document before typesetting - only if they are too large they are moved to the next page (which is fine).

I just thought whether there is some general solution to this problem - this problem does not appear when I change the package option to "print on one side" - it appears only for "print on both sides" which is really strane!

John MacKendrick's picture

If you post a sample document

If you post a sample document or send one to support@mackichan.com, we should be able to offer some insight to this problem and possibly offer a solution.

rynek's picture

Just to let you know and if

Just to let you know and if anyone else is interested:

I solved the problem by using the print on one side option from the class option and then using the print on two sides option from the geometry-package. Now, I do not have anymore problems with large brakes.