BibTex

Hassan's picture

Hi,
I use SWP 5.5. When I Run Bib Tex, I get this message:

I couldn't open file name `C:/swp55/Docs/example2.aux'

Any idea how I can resolve this issue?
Thanks a lot in advance

AttachmentSize
example2.tex3.58 KB

If you open a document and

If you open a document and use Typeset, Tools, Run BibteX before having compiled the document, then you are seeing expected results.  The .aux file is the input file for BibTeX, but it is not created until you first compile the document once.

Use Typeset, Compile and turn on the Generate a Bibliography check box.  This will compile once, then run BibTeX, then compile three more times to make sure all cross references are resolved.

Hassan's picture

Super. It worked. I

Super.
It worked. I completely forgot about that step.
Now it worked fine.
I have another question:
How can I have references numbered and refer to the numbers in the text instead of Name and Year as it is now?
Many thanks again
Hassan

When using BibTeX, this is

When using BibTeX, this is determined by the BibTeX bibliography style you are using. 

Use Help, Search and find the topic "BibTeX bibliography styles" for a description of many of the BibTeX styles.  You can also look at the Shell Gallery document in the manuals directory of the product CD to see how many of the BibTeX bibliography styles appear when typeset.

pviton's picture

Is there in fact such a file?

Is there in fact such a file? If not, you need to create one, which will be done automatically by saving and then previewing your document, though for bibtex you will want to save, then do Tools -> Compile and check "Generate a bibliography". (There are also icons for Compile).

Hassan's picture

Thanks

Thanks